]> git.refcnt.org Git - colorize.git/blobdiff - debian/rules
debian/rules: eliminate trailing whitespace
[colorize.git] / debian / rules
index 0b0627eb00894da39a1528996b0d8bb7011143e0..3ae78b064d130250e8aa6b3ee46989aab1683c8d 100755 (executable)
@@ -1,28 +1,12 @@
 #!/usr/bin/make -f
-# See debhelper(7) (uncomment to enable)
-# output every command that modifies files on the build system.
-#DH_VERBOSE = 1
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
 # see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
 DPKG_EXPORT_BUILDFLAGS = 1
 include /usr/share/dpkg/default.mk
 
-# see FEATURE AREAS in dpkg-buildflags(1)
-#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-
-# see ENVIRONMENT in dpkg-buildflags(1)
-# package maintainers to append CFLAGS
-#export DEB_CFLAGS_MAINT_APPEND  = -Wall -pedantic
-# package maintainers to append LDFLAGS
-#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
-
-
 # main packaging script based on dh7 syntax
 %:
-       dh $@ 
-
-# debmake generated override targets
-# This is example for Cmake (See http://bugs.debian.org/641051 )
-#override_dh_auto_configure:
-#      dh_auto_configure -- \
-#      -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)
+       dh $@